With the new Ircam Forum website coming, the user groups will be migrated towards a new platform.
Please plan user groups downtime between Monday, March 25th and Tuesday, March 26th.

Group Admins

  • Profile picture of Robert P.


Public Group active 4 days, 12 hours ago

Modalys physical modeling sound synthesis user group

loading .mlys script?

Tagged: ,

Author 2 Subscribed Users |
Profile photo of coraliediatkine


Very silly question: how are .mlys scripts loaded in a Max patcher? I tried to send a “read”, “open”.. message to mlys.script and it didn’t like it at all…

I could copy and past the contents of the file, but I am certain there is a smarter way to do so.



July 7, 2016 at 18:28 #18477

Hi Coralie,

You should try the “read” message directly on the modalys~ object !


  • This reply was modified 2 years, 8 months ago by lochard lochard.
July 8, 2016 at 08:56 #18479
Profile photo of coraliediatkine

Thanks Jean

You mean modalys~?
Ok, got it… I guess I am confused between the “old” way (writing scripts with Modalys) and the “new” way.
It does work.
So messages are sent directly to modalys~ ?
By the way, I had copied and pasted (and edited) the script via the mly.script but it wasn’t saved. It doesn’t have a “save data with patcher” option.
So I guess the old way is still up-to-date.

July 8, 2016 at 09:02 #18480

Yes, i made an edit… The mays.script has to be used with the other .mlys object as in this example…

But can steal use the old school method ; you can add ‘dynamic controller to your script with “-1″ instead of “0” as refresh time for the parameter and a small label that will be used to talk to this parameter from max. You will find an example in the next archive…


July 8, 2016 at 09:18 #18484
Profile photo of coraliediatkine

I recently installed Max 7 and tried to run a patch that contains Mlys~ objects. It doesn’t seem to work.Package are probably not recognized.
Is there any specific manipulation to get the Max Apps forum running with Max7 compared to Max6? I can’t visualize the patckages in the Extra menu,and the objects (Mlys, Spat etc) are not found.

I know the spat runs on Max 7.

Does anyone have a clue about that?



July 27, 2016 at 21:01 #18686

You must be logged in to reply to this topic.

Log in now