Group Admins

  • Profile picture of Karim
  • Profile picture of Jean

OpenMusic

Public Group active 19 hours, 1 minute ago

User group for OpenMusic and computer-aided composition. Visit the Forum for discussions.

OM 6.14 (linux) lots of crashes

Author 2 Subscribed Users |
Profile photo of Karim
Karim

Hi

Since I swithched to OM 6.14 (linux version) i get a lot of crashes due to (i suppose) graphical issues :

X ERROR
Display: “:0 {Lispworks}”
Error: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 224 (unknown request name)
Minor opcode of failed request: 0 ()

Any ideas ?

Best
K

October 23, 2018 at 14:11 #28132
Profile photo of anders
anders

Hi Karim.

Seems perhaps to be related to something X.

Is it the same if you use Wayland? Running KDE, Gnome, Wayland, X…? Same behavior across kernels?

Any recurrent behavior, patches which breaks, stages in workflow, further hints?

Sorry to be of little or no help here, but 6.14 seems stable on the system i’m running myself (Fedora, Wayland).

Perhaps there are others here with some reproducable experiences?

-anders

October 23, 2018 at 16:09 #28133
Profile photo of Karim
Karim

hi Anders,

Thanx for the reply.
For info : I am on Debian (stretch) Stable and use i3wm as a window manager. I didn’t use to have such crashes of the X server in the 6.13 version.

Best
K

October 23, 2018 at 16:36 #28134
Profile photo of anders
anders

If you downgrade to 6.13, does it run without crashes on your current system?

It could be something with the .deb-package (built on Ubuntu 18.04.1 on a vm), but this should probably spark some warnings or error messages, or some incompatibility between the system you’re running now and the graphical layer in lw-7.1.

I can’t think of any changes in OMs sources (from 6.13 to 6.14) which could imply something like the crashes you see.

You could of course ask the variuos lw-forums, perhaps they’ve got some suggestions there.

October 23, 2018 at 16:52 #28135
Profile photo of Karim
Karim

I didn’t install OM from the package. Just copied the Folder from the OM_6.14.1.tar.bz2 release ( i think it is the latest ?)
On om6.13 i have some crashes also but not that much.
Maybe it is related to my workspace …

THx
K

October 23, 2018 at 17:25 #28136

You must be logged in to reply to this topic.

Log in now