Group Admins

  • Profile picture of warusfel
  • Profile picture of T.

Spat

Public Group active 9 hours, 36 minutes ago

User group for Spat, panoramix, ToscA , and ADMix

ToscA 0.9.0

Author 2 Subscribed Users |
Profile photo of T.
T.

Dear all,

A new version of ToscA is available.

This new version allows to prefix any incoming/outgoing OSC messages with a given OSC pattern.
The pattern must be specified in the mapping file, and it is applied to all instances of the ToscA plugin.
Please have a look at the user manual for further details.

Using an OSC prefix (typically “/track”) improves compatibility with, e.g., the panoramix application.
If you dont use prefix (leaving the prefix field empty), then ToscA should be fully compatible with previous versions (and DAW sessions).

T.

May 6, 2017 at 14:53 #22313
Profile photo of MrTea
MrTea

Issues with Tosca xml file

Hello I have tried re-writing the xml file for tosca using textedit on OSX like this:
<?xml version=”1.0″ encoding=”UTF-8″ standalone=”yes”?>

<tosca version=”0.4″>
<parameter index=”1″ name=”x” min=”-10″ max=”10″ scaling=”linear”/>
<parameter index=”2″ name=”y” min=”-10″ max=”10″ scaling=”linear”/>
<parameter index=”3″ name=”z” min=”-10″ max=”10″ scaling=”linear”/>
<parameter index=“4” name=”azim” min=”-180″ max=”180″ scaling=”linear”/>
<parameter index=“5” name=”elev” min=”-90″ max=”90″ scaling=”linear”/>
</tosca>

Then saving it as “startup_mapping” in documents/ircam/tosca as specified in the manual. When i launch ableton live 9 it does automatically load this file but only reads the first 3 parameter indexes x, y, z

Interestingly if i click edit from within the ToscA plugin i can see indexes 4, 5 as i want them but they are not visible in the automation lane in ableton live.

Any suggestions on how to get the xml file read properly?

December 14, 2018 at 10:53 #28559
Profile photo of T.
T.

Hello MrTea,

I don’t know if this is a formatting issue on forumnet, but it seems that the quotation characters for “4” and “5” are not the same (as “1”, “2”, or “3”). Maybe that could explain your issue.
Try to make sure the same kind of character is used everywhere.

Best,
T.

December 14, 2018 at 10:59 #28560
Profile photo of MrTea
MrTea

Hello T

SOLVED

Yes that was it thanks. I actually copied the params 4 and 5 from the mapping.xml file in the help documents that come with ToscA so they must be different quotes in there too.

Thanks for your quick response

December 14, 2018 at 11:27 #28561
Profile photo of MrTea
MrTea

Correction the ” ” in the Mapping.xml are the same but when i copy paste this in textedit it changes the shape of them Bizzare! anyway now i know to check this then its solved
Thanks

December 14, 2018 at 11:48 #28562

You must be logged in to reply to this topic.

Log in now